Back to overview
Degraded
Cloudflare Global Network experiencing issues
Nov 18 at 02:08pm CET
Affected services
lease-a-bike.nl
lease-a-bike.de
lease-a-bike.fr
lease-a-bike.com
lease-a-bike.at
lease-a-bike.be
leaseabike.se
vtb.lease-a-bike.nl
contract.lease-a-bike.nl
Resolved
Nov 18 at 03:38pm CET
Cloudflare has resolved the issue.
Affected services
Created
Nov 18 at 02:08pm CET
Currently we are experiencing Cloudflare issues. This is a global matter and Cloudflare is working hard on solving this issue.
Affected services